[ htmlunit-Bugs-1559903 ] no scopes supplied in maven2 pom on ibiblio

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[ htmlunit-Bugs-1559903 ] no scopes supplied in maven2 pom on ibiblio

SourceForge.net
Bugs item #1559903, was opened at 2006-09-16 23:19
Message generated for change (Comment added) made by henryju
You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=448266&aid=1559903&group_id=47038

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: None
Group: None
Status: Open
Resolution: None
Priority: 5
Submitted By: Daniel Gredler (sdanig)
Assigned to: Nobody/Anonymous (nobody)
Summary: no scopes supplied in maven2 pom on ibiblio

Initial Comment:
None of the dependencies listed in
http://www.ibiblio.org/maven2/htmlunit/htmlunit/1.9/htmlunit-1.9.pom
have a scope. Dependencies that are only needed for
unit testing should have a scope of "test". This keeps
users from having to download libraries that htmlunit
only uses for unit testing.

As it stands, I'm trying to use htmlunit 1.9 + jetty
6.0.0 to test my application (managed via maven2). My
jetty 6.0.0 test dependency gets overriden by
htmlunit's jetty 5.1.4 (test?) dependency...


----------------------------------------------------------------------

Comment By: Julien HENRY (henryju)
Date: 2006-09-19 09:04

Message:
Logged In: YES
user_id=1235926

I did a migration from Maven 1 to Maven 2 of HtmlUnit in
March or April, and I sent my work to you. The main issue
was that some directory have to be moved to follow Maven 2
standards, and it was decided to wait SVN migration (as CVS
do not like moving directory).

If you want, you could create a branch from the trunk, and
give me commiter access. I will migrate it to Maven 2 ASAP.

----------------------------------------------------------------------

Comment By: Marc Guillemot (mguillem)
Date: 2006-09-17 14:09

Message:
Logged In: YES
user_id=402164

Best would be to upgrade to maven 2... if someone find time
to do the work.
It seems that scope can be correctly set in maven 1 too
according to comments on htmlunit 1.9 upload request
http://jira.codehaus.org/browse/MAVENUPLOAD-960
Here too is help welcome.

----------------------------------------------------------------------

You can respond by visiting:
https://sourceforge.net/tracker/?func=detail&atid=448266&aid=1559903&group_id=47038

-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys -- and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
HtmlUnit-develop mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/htmlunit-develop